Organization Member Management
Incident Report for Accessible Web
Resolved
This incident has been resolved.
Posted Dec 12, 2022 - 17:16 EST
Identified
We have identified an issue impacting some users abilities to add users to their organizations in RAMP. We are working on a fix for release in the coming hour.
Posted Dec 12, 2022 - 16:06 EST
This incident affected: Accessible Web RAMP.