A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 12:22 EDT
Identified
We've enabled enhanced firewall rules as we mitigate a traffic surge, this is temporarily affecting the Accessibility and Compliance center embeds from loading properly on websites. You may also experience issue authenticating with the Accessible Web Helper Chrome Extension during this time. We will post updates here as we have more to share.
Posted Jun 02, 2026 - 09:41 EDT
This incident affected: Accessible Web RAMP and Accessibility Badge.